Terra Dotta: Intermittent Site Slowness

Incident Report for Terra Dotta

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 14:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 13:43 EDT

Investigating

We are currently investigating intermittent performance issues impacting site responsiveness and speed for some Terra Dotta customers. Our engineering team is actively working to identify the root cause and implement a resolution as quickly as possible.
Posted Sep 08, 2026 - 13:08 EDT
This incident affected: TerraDotta Application Servers (Terra Dotta Web01/02/07 Hosted sites, Terra Dotta Web03/04/08 Hosted sites, Terra Dotta Web01/02/07 SAAS sites, Terra Dotta Web03/04/08 SAAS sites, Terra Dotta Web05/06 Hosted sites, Terra Dotta Web05/06 SAAS sites).