Terra Dotta Outage

Incident Report for Terra Dotta

Resolved

The AWS-related outage has been resolved. We will continue to monitor throughout the day. Please submit a ticket through support.terradotta.com if you encounter any issues.
Posted Oct 20, 2025 - 11:02 EDT

Monitoring

A fix has been implemented and Terra Dotta sites are accessible now. We will continue to monitor.
Posted Oct 20, 2025 - 09:27 EDT

Investigating

Terra Dotta sites are experiencing an outage originating from our upstream provider. We appreciate your patience and will provide updates as they become available.
Posted Oct 20, 2025 - 08:30 EDT
This incident affected: TerraDotta Application Servers (Terra Dotta Web01/02/07 Hosted sites, Terra Dotta Web03/04/08 Hosted sites, Terra Dotta Web01/02/07 SAAS sites, Terra Dotta Web03/04/08 SAAS sites, Terra Dotta Web05/06 Hosted sites, Terra Dotta Web05/06 SAAS sites).