Terra Dotta Outage on US Sites

Incident Report for Terra Dotta

Resolved

This issue has been resolved. We will continue to closely monitor site availability. Please report any further site degradations or performance issues via the Terra Dotta Help Center.
Posted Apr 15, 2025 - 11:16 EDT

Investigating

We are aware of reports of site inaccessibility and are investigating urgently. More information will be posted to the status page as it is available.
Posted Apr 15, 2025 - 10:40 EDT
This incident affected: TerraDotta Application Servers (Terra Dotta Web01/02/07 Hosted sites, Terra Dotta Web03/04/08 Hosted sites, Terra Dotta Web01/02/07 SAAS sites, Terra Dotta Web03/04/08 SAAS sites, Terra Dotta Web05/06 Hosted sites, Terra Dotta Web05/06 SAAS sites).